pypi package 'zesty-zbs-api'

Popularity: Medium (more popular than 90% of all packages)
Description: Zesty Disk API
Installation: pip install zesty-zbs-api
Last version: 1.0.2022.11.23.1669216547 (Download)
Homepage: https://github.com/javatechy/dokr
Size: 19.69 kB
License:

Activity

Last modified: November 23, 2022 3:15 PM (3 days ago)
Versions released in one year: 36
Weekly downloads: 696
12/05/202102/20/202205/08/202207/24/202210/09/202202505007501,00001234released versions / week
  • Versions released
  • Weekly downloads

Readme

Description

Zesty Disk API

Installation

pip install zesty.zbs-api

Usage

from zesty.zbs-api import *

Alembic and Postgres Data Models.

For instructions on how to manage the Postgres data model as well as using Alembic to automatically prepare database migrations, please refer to the README.md in the alembic folder which is located at the root of this repository.

SQLAlchemy Dependency

Some of the models within this package require SQLAlchemy to be imported. To keep this package light as it's used across many places in our code base, we do not install SQLAlchemy with this package. Thus, if you need to use any of the models that depend on SQLAlchemy, please install the Postgres-Utils package with your requirements.txt.